2013年08月06日

プラグインのアップデートでトラブルの巻

WordPress の管理画面に行くと、プラグインのアップデート表示が。じゃあアップデートしてみましょうかとクリックするとまたしてもエラーが。
古いプラグインを削除出来ませんでした
「古いプラグインを削除出来ませんでした。」とな。
なんだかディレクトリの権限っぽい感じですね。

とおもって、wp-content やwp-content/plugin のパーミッションを777にしたり、ユーザーを appache にしたりとやってみたけどダメ。
にゃんだよ〜。

だいぶんハマったあとでふと、プラグインが入っているディレクトリのユーザーを変えてみようと思い立った。
おおもとの plugin ディレクトリではなくて、そのなかのディレクトリね。
こんかい対象ブラグインのディレクトリ名は akismet なので、コマンドはこう。wp-content にいるとして、
 chown apache:apache plugin/akismet

するとあっさり成功。
プラグインの更新に成功しました。
そうですか対象ディレクトリのユーザーを変えないとダメですか。多分わかってる人には当たり前なんだろうなぁ。
もう wp-content 以下のディレクトリとファイルは全部 apache の持ち物にしてやる!
ルートにいるとして、
 chown -R apache:apache wp-content

パーミッションも 707 や 777 にしてたのを 755 に変えてみる。安全対策?いいえ、気分の問題です。
 chown 755 wp-content

これで権限関係のトラブルは全てなくなるのでしょうか。そんなわけないよなぁ、きっと。


posted by 万年初心者 at 20:31| Comment(0) | TrackBack(0) | トラブルと対処 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

※ブログオーナーが承認したコメントのみ表示されます。

この記事へのトラックバック
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。